[trunk] -> [community-staging] 'geany-plugins-1.38-3' add

master
Dudemanguy 10 months ago
parent 5530a208f9
commit b05372aa8d
  1. 14
      trunk/PKGBUILD
  2. 22
      trunk/geany-plugins-1.38-libgit2_1.4.patch
  3. 50
      x86_64/community-staging/PKGBUILD
  4. 22
      x86_64/community-staging/geany-plugins-1.38-libgit2_1.4.patch

@ -5,19 +5,27 @@
pkgname=geany-plugins
pkgver=1.38
pkgrel=2
pkgrel=3
pkgdesc='Plugins for Geany'
arch=(x86_64)
url='https://plugins.geany.org/'
license=(GPL)
depends=(ctpl "geany>=$pkgver" gpgme gtkspell3 libgit2 lua51 python vte3 webkit2gtk)
makedepends=(cppcheck intltool)
source=("$url$pkgname/$pkgname-$pkgver.tar.bz2"{,.sig})
source=(
"$url$pkgname/$pkgname-$pkgver.tar.bz2"{,.sig}
$pkgname-1.38-libgit2_1.4.patch
)
b2sums=('a2fd9e59218e4b5359b910ccff8d0a6504845081f827d2f1c798ea6401914e8e01222c784a76ab0a126f5fe07c8aa86018cef4c71bb5e2891193f6c8965a3e47'
'SKIP')
'SKIP'
'8daf8357caf09eb62844b6c44fa2a819231879b6d7e69bde4039f87230419cf371d1e8b5dede2f23dbb65d5d652b0bce3e51c79164ab8e3d76b445130cd5d387')
validpgpkeys=('986FA7E80256D3D16F30FB7A01380DF54FD09D02') # Frank Lanitz <frank@geany.org>
prepare() {
# fix for changes to git_buf with libgit2 >= 1.4
# https://github.com/geany/geany-plugins/issues/1164
patch -d $pkgname-$pkgver -p1 -i ../$pkgname-1.38-libgit2_1.4.patch
cd $pkgname-$pkgver
autoreconf -fi

@ -0,0 +1,22 @@
diff --git i/git-changebar/src/gcb-plugin.c w/git-changebar/src/gcb-plugin.c
index f8ce20cd..4488b22f 100644
--- i/git-changebar/src/gcb-plugin.c
+++ w/git-changebar/src/gcb-plugin.c
@@ -216,7 +216,7 @@ static int
gcb_git_buf_grow (git_buf *buf,
size_t target_size)
{
- if (buf->asize == 0) {
+ if (buf->reserved == 0) {
if (target_size == 0) {
target_size = buf->size;
}
@@ -234,7 +234,7 @@ buf_zero (git_buf *buf)
if (buf) {
buf->ptr = NULL;
buf->size = 0;
- buf->asize = 0;
+ buf->reserved = 0;
}
}

@ -0,0 +1,50 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
# Contributor: Angel 'angvp' Velasquez <angvp@archlinux.org>
# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@gmail.com>
# Contributor: Patrick Melo <patrick@patrickmelo.eti.br>
pkgname=geany-plugins
pkgver=1.38
pkgrel=3
pkgdesc='Plugins for Geany'
arch=(x86_64)
url='https://plugins.geany.org/'
license=(GPL)
depends=(ctpl "geany>=$pkgver" gpgme gtkspell3 libgit2 lua51 python vte3 webkit2gtk)
makedepends=(cppcheck intltool)
source=(
"$url$pkgname/$pkgname-$pkgver.tar.bz2"{,.sig}
$pkgname-1.38-libgit2_1.4.patch
)
b2sums=('a2fd9e59218e4b5359b910ccff8d0a6504845081f827d2f1c798ea6401914e8e01222c784a76ab0a126f5fe07c8aa86018cef4c71bb5e2891193f6c8965a3e47'
'SKIP'
'8daf8357caf09eb62844b6c44fa2a819231879b6d7e69bde4039f87230419cf371d1e8b5dede2f23dbb65d5d652b0bce3e51c79164ab8e3d76b445130cd5d387')
validpgpkeys=('986FA7E80256D3D16F30FB7A01380DF54FD09D02') # Frank Lanitz <frank@geany.org>
prepare() {
# fix for changes to git_buf with libgit2 >= 1.4
# https://github.com/geany/geany-plugins/issues/1164
patch -d $pkgname-$pkgver -p1 -i ../$pkgname-1.38-libgit2_1.4.patch
cd $pkgname-$pkgver
autoreconf -fi
# don't redefine bool
sed -i 's/typedef unsigned int bool/#include <stdbool.h>/g' \
pretty-printer/src/PrettyPrinter.h
}
build() {
cd $pkgname-$pkgver
export CFLAGS+=' -w'
export PYTHON=/usr/bin/python
./configure --prefix=/usr --libexecdir=/usr/lib
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
}
# getver: plugins.geany.org/downloads.html

@ -0,0 +1,22 @@
diff --git i/git-changebar/src/gcb-plugin.c w/git-changebar/src/gcb-plugin.c
index f8ce20cd..4488b22f 100644
--- i/git-changebar/src/gcb-plugin.c
+++ w/git-changebar/src/gcb-plugin.c
@@ -216,7 +216,7 @@ static int
gcb_git_buf_grow (git_buf *buf,
size_t target_size)
{
- if (buf->asize == 0) {
+ if (buf->reserved == 0) {
if (target_size == 0) {
target_size = buf->size;
}
@@ -234,7 +234,7 @@ buf_zero (git_buf *buf)
if (buf) {
buf->ptr = NULL;
buf->size = 0;
- buf->asize = 0;
+ buf->reserved = 0;
}
}
Loading…
Cancel
Save