Calamares Artix flavor
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
linuxer 073a1d6dca
Changed Slideshow background color
2 years ago
3rdparty Initial commit 2 years ago
CMakeModules Initial commit 2 years ago
LICENSES Initial commit 2 years ago
ci Initial commit 2 years ago
data Initial commit 2 years ago
lang Initial commit 2 years ago
man Initial commit 2 years ago
src Changed Slideshow background color 2 years ago
.clang-format Initial commit 2 years ago
AUTHORS Initial commit 2 years ago
CHANGES Initial commit 2 years ago
CMakeLists.txt Initial commit 2 years ago
CalamaresBuildTreeSettings.cmake.in Initial commit 2 years ago
CalamaresConfig.cmake.in Initial commit 2 years ago
CalamaresConfigVersion.cmake.in Initial commit 2 years ago
CalamaresUse.cmake.in Initial commit 2 years ago
Dockerfile Initial commit 2 years ago
LICENSE Initial commit 2 years ago
README.md Updated README.md 2 years ago
calamares-master.pro Initial commit 2 years ago
calamares-master.pro.user Initial commit 2 years ago
calamares.desktop Initial commit 2 years ago
calamares.desktop.in Initial commit 2 years ago
cmake_uninstall.cmake.in Initial commit 2 years ago
com.github.calamares.calamares.policy Initial commit 2 years ago
io.calamares.calamares.appdata.xml Initial commit 2 years ago
settings.conf Initial commit 2 years ago

README.md

Forked and Rebranded for Artix Linux

Calamares: Distribution-Independent Installer Framework


GitHub release Travis Build Status GitHub license

Report a Bug Translate Contribute Freenode (IRC): #calamares Wiki

Dependencies

Main:

  • Compiler with C++14 support: GCC >= 5 or Clang >= 3.5.1
  • CMake >= 3.3
  • Qt >= 5.9
  • yaml-cpp >= 0.5.1
  • Python >= 3.3 (required for some modules)
  • Boost.Python >= 1.55.0 (required for some modules)
  • KDE extra-cmake-modules >= 5.18 (recommended; required for some modules; required for some tests)
  • KDE Frameworks KCoreAddons (>= 5.58 recommended)
  • PythonQt (optional, deprecated)

Modules:

  • Individual modules may have their own requirements; these are listed in CMake output. Particular requirements (not complete):
  • fsresizer KPMCore >= 3.3
  • partition KPMCore >= 3.3
  • users LibPWQuality (optional)

Building

See wiki for up to date building and deployment instructions.